In this part we are going to look at the anycast gateway setup of the topology. This will help get the servers off their local network.

Lets remind ourselves of the topology:

Image

The layout itself hasn't changed. However, server3 has been moved onto Vlan20 so we can show routing using L3VNIs later.

Anycast gateways will be configured on each of the leaves using a virtual mac address so that mobility can be achieved without having to re-arp for the gateway MAC address. The same IP and MAC will be configured on each leaf.

Anycast basically means that everything has the same IP address and the closest instance of that IP address will be used when its requested. This is how services like Cloudflare work so you are routed to the closest node into their network. Due to this being anycast, it means we don't need to use HSRP which is common when doing a vPC deployment.

Vlan20 L2VNI

Lets quickly create the L2VNI for Vlan20 on LEAF-5 and LEAF-6 for the server to move:

vlan 20
  vn-segment 100020

interface nve1
  member vni 100020
    suppress-arp
    mcast-group 224.1.1.192

evpn
  vni 100020 l2
    rd auto
    route-target import auto
    route-target export auto

interface port-channel2
  switchport access vlan 20

Virtual Anycast MAC address

This anycast mac address should be configured on each leaf:

fabric forwarding anycast-gateway-mac aaaa.bbbb.cccc

We will see this Mac address in the ARP table of the clients as the Gateway.

SVI Configuration

Now, we can configure the SVI interfaces with the anycast IP addresses. In this topology we have vlan 10 and 20. This configuration is for all leaves:

interface Vlan10
  no shutdown
  ip address 10.1.1.254/24
  fabric forwarding mode anycast-gateway

interface Vlan20
  no shutdown
  ip address 10.2.1.254/24
  fabric forwarding mode anycast-gateway

Verification

Now, we can verify the configuration by trying to ping the local anycast gateway from a server:

Image

Image

We can see the pings are successful and also we can see the virtual mac address of the gateway too from the local arp table.

In the next part, we will move onto the L3VNI section. Just having anycast gateways doest't give us layer 3 connectivity between vlan 10 and vlan 20, we need some other things layered on top.

0 Comments

Leave a Reply

Avatar placeholder

Your email address will not be published. Required fields are marked *